A place to discuss about The Protectors mod for Warlords Battlecry 3. Visit http://the-protectors.webs.com for more info.
 
HomeCalendarFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 [FIXED] AI Problems 2: Revenge of the Bugs

View previous topic View next topic Go down 
AuthorMessage
Joe the Bartender
Keeper of Balance
Keeper of Balance
avatar

Posts : 326
Join date : 2014-08-20
Location : The Candlekeep Inn

PostSubject: [FIXED] AI Problems 2: Revenge of the Bugs   Tue Apr 14, 2015 8:40 am

This one has been locked out, otherwise I would've mentioned it there Rolling Eyes.

Just when I thought there wasn't anything else to report about this topic, some bugs have risen from the grave. It could just be occurring on my end, but just in case it isn't I'll catch them in the act and upload my hero data if needed.

The first one is about targeting priority. The AI don't prioritise players any more, but I've noticed that the AI now rarely attacks me at all if ever (even with Warlord/Emperor AIs).

The second one is essentially this:
Joe the Bartender wrote:
At a later point in the game ... the AI freezes and refuses to produce units
This thing is still running around, and this time it doesn't seem to be anything to do with the unit production cap (when I killed an AI hero, they spawned units via an RSB). I played a game against some Warlords/Emperors, and when AI main lvl3 mine resources hit ~ 7500, they stopped producing units. I think it was around the time a Titan came out (Balora in this case). Another weird thing I noticed was that the AI with Balora had a large pile of units sat in the middle of the map doing nothing at all. It's like the AI just had a major brainfart scratch.

Lastly I can't remember if this has been fixed already or not, but in 0.8.4a some AI units are still self-destructing when attacking things.
Back to top Go down
View user profile http://etheria.wikia.com/wiki/User_talk:Joe_the_Bartender
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 894
Join date : 2012-01-04

PostSubject: Re: [FIXED] AI Problems 2: Revenge of the Bugs   Sat Apr 18, 2015 6:59 pm

Well the Daemon AI has a particularity in that it never attacks with Summoners. The idea is to keep them in the base and just use them to spawn daemons and defend, though as I observed sometimes they just quit the spawning (maybe reaching the army limit?)

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 894
Join date : 2012-01-04

PostSubject: Re: [FIXED] AI Problems 2: Revenge of the Bugs   Mon Apr 20, 2015 3:10 am

Joe the Bartender wrote:

Lastly I can't remember if this has been fixed already or not, but in 0.8.4a some AI units are still self-destructing when attacking things.
- fixed in 0.8.5.

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 894
Join date : 2012-01-04

PostSubject: Re: [FIXED] AI Problems 2: Revenge of the Bugs   Sun Aug 21, 2016 6:12 am

Fixed in 0.8.7. Topic closed.

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Sponsored content




PostSubject: Re: [FIXED] AI Problems 2: Revenge of the Bugs   

Back to top Go down
 
[FIXED] AI Problems 2: Revenge of the Bugs
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» DARKSEID BAF Problems...
» (Fixed) Norton doesn't like TFN!
» Photobucket Problems
» WOLFENSTEIN: THE ULTIMATE REVENGE
» Revenge Of The Nerds 1-4 [DVDRip]

Permissions in this forum:You cannot reply to topics in this forum
The Protectors Forum :: Bugs reporting-
Jump to: