A place to discuss about The Protectors mod for Warlords Battlecry 3. Visit http://the-protectors.webs.com for more info.
 
HomeCalendarFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 [0.8.7] Game won't start

View previous topic View next topic Go down 
Go to page : 1, 2  Next
AuthorMessage
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: [0.8.7] Game won't start   Sat Dec 24, 2016 6:30 am

OS: Win XP SP3

Just downloaded the latest version released today. Unfortunately, the game crashed while attempting to start up even though I uninstalled previous version and deleted "The Protectors" folders in Documents.

Game window/screen never came out and is not shown as task at all. However, it is shown on processes for a few seconds and then is gone! Sad

P.S. I am able start 0.8.6 just fine though that version tends to crash randomly while in battle.
Back to top Go down
View user profile
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 939
Join date : 2012-01-04

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 6:48 am

Don't forget to run the game in compatibility mode. Right click The Protectors.exe -> properties-> compatibility -> check run in compatibility for windows xp sp2.
Also run as admin.

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 6:54 am

As I am already using Windows XP as my operating system, I do not require compatibility settings to run the game. I could start 0.8.6 without any compatibility settings whatsoever but not 0.8.7.
Back to top Go down
View user profile
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 939
Join date : 2012-01-04

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 7:13 am

Try deleting the Videos folder see if that helps.

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 7:39 am

I've deleted the video folder under [Program Files/The Protectors], but the game still won't start.


Last edited by Edulf on Sat Dec 24, 2016 8:43 pm; edited 1 time in total
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 8:38 pm

I've checked the Startup.log under [My Documents/The Protectors] which is created every time I attempted to launch this game.

The log seems to show the game crashed at "Initializing Resources".
Back to top Go down
View user profile
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 939
Join date : 2012-01-04

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 9:18 pm

Sounds like a faulty install. Anyway, a player suggested:
Quote :
I have two way for you, the first is press the Alt+enter when as fast as the picture become black, you might enter, and change the resolution for your computer.
The second is completely delete the 0.86, and use the Regedit.exe to delete the old 'The protectors' file. GOOD luck to you^^

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 939
Join date : 2012-01-04

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 9:39 pm

I get the same startup log if i am not running in compatibility mode for winxp SERVICE PACK 2

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 10:13 pm

Patrick_the_Winekiller wrote:
Sounds like a faulty install. Anyway, a player suggested:
Quote :
I have two way for you, the first is press the Alt+enter when as fast as the picture become black, you might enter, and change the resolution for your computer.
The second is completely delete the 0.86, and use the Regedit.exe to delete the old 'The protectors' file. GOOD luck to you^^

The 1st method is not applicable to me as the game window or screen did not appear at all. Only the process appear on task manager, but it last for a few seconds only.

I tried the 2nd method which I've deleted all references of The Protectors in registry and folders that sadly did not work also.
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 10:22 pm

Patrick_the_Winekiller wrote:
I get the  same startup log if i am not running in compatibility mode for winxp SERVICE PACK 2

I am already running Windows XP SP3. As for compatibility mode, only win 95, win 98, win nt 4.0 and win 2000 are available for my OS.
Back to top Go down
View user profile
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 939
Join date : 2012-01-04

PostSubject: Re: [0.8.7] Game won't start   Sat Dec 24, 2016 11:34 pm

Try any of those, maybe they will work.

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 12:45 am

I am able to launch the game with win 98 among the choices of compatibility modes I have, but the screen is all black except the video part and is also not full screen. I am starting to miss 0.8.6 Crying or Very sad
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 1:39 am

The 1st suggestion to alt-enter the black screen for this win 98 compatibility mode did not work either which I did tried many times.
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 1:42 am

The parts that work with win 98 compatibility mode are the intro video and the thumbnail video on the right of menu buttons. Rest is all black.
Back to top Go down
View user profile
Joe the Bartender
Keeper of Balance
Keeper of Balance
avatar

Posts : 341
Join date : 2014-08-20
Location : The Candlekeep Inn

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 2:04 am

Does it give a crash message or does it just disappear?

Could there be any external influences, such as antivirus software?

Have you got fully updated drivers?
Back to top Go down
View user profile http://etheria.wikia.com/wiki/User_talk:Joe_the_Bartender
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 2:59 am

It just close by itself as a process (no task or window ever appears). No message.

The only sort of antivirus I have is Malwarebytes Premium and I am sure it's not cause by this as I have tested before, and I also could start and play 0.8.6 without much trouble except occasional random crashes but that another story.

With 0.8.7, I am not even able to start the game on my native Windows XP like I could with 0.8.6. Although by using win 98 compatibility mode, the situation is slightly better as the game could be started, but everything is black except videos(intro and embed).

My drivers are updated enough to run anything that are supposed to run on XP with SP3. Maybe because 0.8.7 is designated for XP SP2 and not SP3. Perhaps a patch could help if this the case since my XP is SP3.
Back to top Go down
View user profile
jalonsdale
Squire
Squire
avatar

Posts : 2
Join date : 2016-03-14

PostSubject: TPC WinXP / Comp Patch   Sun Dec 25, 2016 6:40 am

Some features may require windows XP Compat, but expect Windows Vista or later. A good example of this kind of stuff may involve things like TPC and DDO, DDO however is a published game, while TPC is still beta. Still however bugs like these still exist within the windows environment. As a heads up just because it says windows xp compatability in a higher system, doesn't mean windows xp it's self can run it.

I can run a VBOX of Windows XP, see if that will help trouble shoot it, but give me some time on this matter as a disk of Windows XP is indeed hard to come by.
Back to top Go down
View user profile
Patrick_the_Winekiller
Devourer of bugs
Devourer of bugs
avatar

Posts : 939
Join date : 2012-01-04

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 7:31 am

What does the startup log say when you successfully enter the game via win 98?

_________________

Back to top Go down
View user profile http://the-protectors.webs.com
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 12:14 pm

Patrick_the_Winekiller wrote:
What does the startup log say when you successfully enter the game via win 98?

Here's the log. It looks okay to me but the game screen is pure black except video.

---------------
Initializing files & directories
Reading Help Status
Reading Advanced Options
Reading Standard Options
Checking hero data file
Files have been successfully initialized
--------------------------------------------------------------------------------
Initializing Comms System
Comms System been successfully initialized
--------------------------------------------------------------------------------
Initializing Resources
Adding Terrain Packs
  Adding: Caverns.xcr
  Adding: Chasm.xcr
  Adding: Desert Cliffs.xcr
  Adding: Desert Coast.xcr
  Adding: Desert.xcr
  Adding: Dirt.xcr
  Adding: DirtMountains.xcr
  Adding: Grass Coast.xcr
  Adding: Grass.xcr
  Adding: High Dirt.xcr
  Adding: High Grass.xcr
  Adding: Ice.xcr
  Adding: Jungle.xcr
  Adding: Lava.xcr
  Adding: Marsh.xcr
  Adding: Mountains.xcr
  Adding: Paving.xcr
  Adding: Platform.xcr
  Adding: Pyramid.xcr
  Adding: Rock Cliffs.xcr
  Adding: Rock Coast.xcr
  Adding: Rock.xcr
  Adding: Snow Coast.xcr
  Adding: Snow.xcr
  Adding: W3AncientTemple.XCR
  Adding: Water.xcr
  Adding: ZExtoriasCave.xcr
  Adding: ZZWBC1 Terrain.xcr
  Adding: ZZWBC2 Terrain.xcr
Adding Feature Packs
  Adding: AncientFoliage.xcr
  Adding: AncientTemple.xcr
  Adding: CaveExtorias.xcr
  Adding: CavernsFeatures.XCR
  Adding: Civil.xcr
  Adding: Coastal.xcr
  Adding: DeadTrees.xcr
  Adding: DesertTrees.xcr
  Adding: GrassPlants.xcr
  Adding: GrassTrees.xcr
  Adding: KingStuff.xcr
  Adding: Rocks.xcr
  Adding: Ruins.xcr
  Adding: SnowMisc.xcr
  Adding: SnowTrees.xcr
  Adding: War.xcr
  Adding: YMisc.xcr
  Adding: ZAudio.xcr
  Adding: ZEffects.xcr
Adding Side Packs
  Adding: Barbarians.xcr
  Adding: BarbariansVoicesEn.xcr
  Adding: Boats.xcr
  Adding: BoatsVoicesEn.xcr
  Adding: Daemons.xcr
  Adding: DaemonsVoicesEn.xcr
  Adding: DarkDwarves.xcr
  Adding: DarkDwarvesVoicesEn.xcr
  Adding: DarkElves.xcr
  Adding: DarkElvesVoicesEn.xcr
  Adding: DragonRace.xcr
  Adding: DragonRaceVoicesEn.xcr
  Adding: Dragons.xcr
  Adding: DragonsVoicesEn.xcr
  Adding: Dwarves.xcr
  Adding: DwarvesVoicesEn.xcr
  Adding: Empire.xcr
  Adding: EmpireVoicesEn.xcr
  Adding: Fey.xcr
  Adding: FeyVoicesEn.xcr
  Adding: Fliers.xcr
  Adding: FliersVoicesEn.xcr
  Adding: Heroes.xcr
  Adding: HeroesVoicesEn.xcr
  Adding: HighElves.xcr
  Adding: HighElvesVoicesEn.xcr
  Adding: Knights.xcr
  Adding: KnightsVoicesEn.xcr
  Adding: LairsShops.XCR
  Adding: Minotaurs.xcr
  Adding: MinotaursVoicesEn.xcr
  Adding: Misc.xcr
  Adding: MiscVoicesEn.xcr
  Adding: Orcs.xcr
  Adding: OrcsVoicesEn.xcr
  Adding: PatBuildings.xcr
  Adding: PatCharacters.xcr
  Adding: PatCharactersVoicesEn.xcr
  Adding: Plaguelords.xcr
  Adding: PlagueLordsVoicesEn.xcr
  Adding: Resources.xcr
  Adding: Siege.xcr
  Adding: SiegeVoicesEn.xcr
  Adding: Ssrathi.xcr
  Adding: SsrathiVoicesEn.xcr
  Adding: Swarm.xcr
  Adding: SwarmVoicesEn.xcr
  Adding: Temples.xcr
  Adding: TemplesVoicesEn.xcr
  Adding: TowersWalls.xcr
  Adding: Undead.xcr
  Adding: UndeadVoicesEn.xcr
  Adding: WoodElves.xcr
  Adding: WoodElvesVoicesEn.xcr
Adding Effect Packs
  Adding: Effects1.xcr
  Adding: PatchEffects.xcr
Adding GameSpeech.xcr
Adding Assets\SoundFX.xcr
Adding Quest.xcr
Adding Graphics.xcr
Adding Powerups.xcr
Adding Panels.xcr
Adding GText.xcr
Adding Portraits.xcr
Resources have been successfully initialized
--------------------------------------------------------------------------------
Initializing the graphics system
  Selected graphics mode 800x600x32
  Opening up in windowed mode
     Main Window has been created
     Initializing sound system
     Opening channels
     Checking for 3d provider
     Initializing music system
        Sound system complete
     Read in XCG file
     Initialize DirectDraw
     Creating DirectDraw Object
     Get Exclusive mode
     Set Display mode
     Create Primary Surface
     Create Back Buffer
     This surface is a 565 surface
     Initialize DirectDraw Gamma
     DirectDraw has been successfully opened
  Setting gamma levels
  --------------------------------------------------------------------------------
  Initializing the interface system
  Using the following language directory:
  Interface system successfully initialized
  --------------------------------------------------------------------------------
  Initializing the font system
  Font system successfully initialized
  Initial file caching
  Defining font families
  Performing state initialization
  Task switching is OFF
  Video System Initialized
  Particle Paths Initialized
  Game Timer Initialized
  Options Data Initialized
  Ability Data Initialized
  Attitude Configuration Initialized
  Item Manager Initialized
  Timer Event Initialized
  Enter through main menu...
     Play video first
     Playing Logo.bik from
     Playing has started successfully


Last edited by Edulf on Sun Dec 25, 2016 9:11 pm; edited 1 time in total
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 12:19 pm

jalonsdale wrote:
Some features may require windows XP Compat, but expect Windows Vista or later. A good example of this kind of stuff may involve things like TPC and DDO, DDO however is a published game, while TPC is still beta. Still however bugs like these still exist within the windows environment. As a heads up just because it says windows xp compatability in a higher system, doesn't mean windows xp it's self can run it.

I can run a VBOX of Windows XP, see if that will help trouble shoot it, but give me some time on this matter as a disk of Windows XP is indeed hard to come by.

But I could run vanilla WB3 and 0.8.6 just fine. Something broke or maybe a new feature prevent me from playing running 0.8.7. The funny thing is I could launch the game using Win 98 or even Win 95 Compatibility mode surprisingly.


Last edited by Edulf on Sun Dec 25, 2016 2:28 pm; edited 2 times in total
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 12:50 pm

After looking at the log again, I finally found the reason for the black screen when using win 98 compatibility. It's because 0.8.7 for some reasons only supports up to 1024x768 with 16bit display. After downgrading my desktop resolution from 1280x800 with 32bit to this and using win 98 compatibility mode, I was able to run the game properly.

Here's the part of the log which I have not posted previously that reveals the cause. Also for some reasons, the game incorrectly identify my desktop res as 1280x742.

OS:         Windows 98
DirectX:    DirectX 9.0
--------------------------------------------------------------------------------
Starting Warlords Battlecry III
Parsing the command line:
Initializing string library
Check the CD is in the drive
--------------------------------------------------------------------------------
Graphics Adapter: ATI Mobility Radeon X2300
Graphics Driver: ati2dvag.dll
        Version: 6.14.10.6925
 Supported Mode: 640x480x16 (60Hz) (565)
 Supported Mode: 640x480x16 (72Hz) (565)
 Supported Mode: 640x480x16 (75Hz) (565)
 Supported Mode: 640x480x16 (85Hz) (565)
 Supported Mode: 640x480x16 (90Hz) (565)
 Supported Mode: 640x480x16 (100Hz) (565)
 Supported Mode: 640x480x16 (120Hz) (565)
 Supported Mode: 640x480x16 (160Hz) (565)
 Supported Mode: 640x480x16 (200Hz) (565)
 Supported Mode: 800x600x16 (60Hz) (565)
 Supported Mode: 800x600x16 (70Hz) (565)
 Supported Mode: 800x600x16 (72Hz) (565)
 Supported Mode: 800x600x16 (75Hz) (565)
 Supported Mode: 800x600x16 (85Hz) (565)
 Supported Mode: 800x600x16 (90Hz) (565)
 Supported Mode: 800x600x16 (100Hz) (565)
 Supported Mode: 800x600x16 (120Hz) (565)
 Supported Mode: 800x600x16 (160Hz) (565)
 Supported Mode: 800x600x16 (200Hz) (565)
 Supported Mode: 1024x768x16 (60Hz) (565)
 Supported Mode: 1024x768x16 (70Hz) (565)
 Supported Mode: 1024x768x16 (72Hz) (565)
 Supported Mode: 1024x768x16 (75Hz) (565)
 Supported Mode: 1024x768x16 (85Hz) (565)
 Supported Mode: 1024x768x16 (90Hz) (565)
 Supported Mode: 1024x768x16 (100Hz) (565)
 Supported Mode: 1024x768x16 (120Hz) (565)
 Supported Mode: 1024x768x16 (150Hz) (565)
 Supported Mode: 1024x768x16 (160Hz) (565)
 Supported Mode: 1024x768x16 (200Hz) (565)
--------------------------------------------------------------------------------
Testing game resolution (desktop res = 1280x742)


Last edited by Edulf on Sun Dec 25, 2016 9:14 pm; edited 3 times in total
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 1:30 pm

When using win 98 compatibility, switching to full screen makes the screen black again unfortunately.


Last edited by Edulf on Sun Dec 25, 2016 3:32 pm; edited 1 time in total
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 3:28 pm

Using a different laptop with newly installed xp sp3 to check if is indeed driver issue. It seems that on this computer I am not able to run the protectors either.

This time an error message came out.

---Error Signature---
AppName: theprotectors.exe
AppVer: 0.8.7.0
ModName: ntdll.dll
ModVer: 5.1.2600.5755
Offset: 00010fa6
---

My original laptop did not report any error was probably because I disabled Error Reporting Service.
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Sun Dec 25, 2016 9:40 pm

While solving this bug is still underway. I just wanna say Merry Christmas to everyone on the forum. santa Oh, and many thanks to the admins for your dedication in creating this mod. I always felt WB3 has potentials but the original as it is seems incomplete.
Back to top Go down
View user profile
Edulf
Lord
Lord
avatar

Posts : 21
Join date : 2016-08-10
Age : 26
Location : Solhaven

PostSubject: Re: [0.8.7] Game won't start   Tue Dec 27, 2016 2:20 am

I managed to finish a skirmish vs bots without any crash using windows 98 compatibility with 1024x768 16-bit res. But there seems to 3 problems I am aware of. Firstly, turning on full screen brings back the black screen issue.  Secondly, despite having desktop resolution of 1024x768, the game itself only manage to run without any screen issues on it's default 800x600 res. Increasing the game res lead to black screen except this time small areas around my mouse pointer will reveal parts of the game screen. Lastly, the battle panel during my skirmish game took up nearly 1/2 of the game screen causing parts of building menu to be covered by the panel.


Last edited by Edulf on Tue Dec 27, 2016 4:33 am; edited 1 time in total
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: [0.8.7] Game won't start   

Back to top Go down
 
[0.8.7] Game won't start
View previous topic View next topic Back to top 
Page 1 of 2Go to page : 1, 2  Next
 Similar topics
-
» Game Will not Start after Migrating to Mod Organizer
» Before you patch *Game Wil Not Start After Patched
» Fallout new vegas: Cant start a new game?
» Game reset
» This game sure can be adamant about wanting players to take certain weapons

Permissions in this forum:You cannot reply to topics in this forum
The Protectors Forum :: Bugs reporting-
Jump to: